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Introducing ID Flow
ID Flow is premier software for ID card design, production and data management.
This guide provides basic understanding of product components and how to get started.
This guide is a supplement to the Help Menu provided within the product. The built-in
Help Menu provides comprehensive configuration details for each dialog.
There are two primary ID Flow interfaces:
Card Designer

Card Issue Center

Use the Card Designer to create your card designs and point them to the appropriate
data source. Once the designs are completed and saved, import the designs into the
Card Issue Center for production and data management.

The Quick Start Option
Quick Start Option 1:
ID Flow Card Issue Center is preconfigured with six Workstation Profiles. These profiles
allow users to select an application that resembles their intended use. They include
Basic ID Card, Advanced ID Card, Corporate ID Card, Student ID Card, Contractor ID Card
and Healthcare ID Card. Profiles are configured with sample databases, sample badge
designs, menu options and enrollment processes that are appropriate for the
application.

The Basic group has six data fields and a single‐layer card design. The Advanced group
has additional fields, including signature and fingerprint fields, and a multi ‐layered card
design. These card designs are linked to a sample database that includes four sample
records. The card designs, data and data fields may be modified.
To use a pre‐configured profile to get started, click on the profile and click Next.
Getting to configuration
Configuration is done through the Setup button on the Main Menu or through the
Admin Menu. Only users with Administrative Rights can change settings. After clicking
Setup you may choose to configure Global or Workstation Settings. There is a shortcut
next to the Cardholder Group that will go directly to the Cardholder Group Properties
dialog. The Record Center button takes you to the database view of all records.

Click on Record Center to see the fields that are pre‐configured in the database.
Editing Card Design
Select Edit Card Design in the drop‐list by clicking on the down arrow next to the Print
button in Record Center or through the blue hyperlink below the card design rendering:

This will launch ID Flow Designer. There is a tool tips dialog that appears when Designer
is launched. It is very useful to page through these.

In ID Flow Designer, design objects may be moved and resized with the mouse, deleted
by selecting delete while the object is highlighted and edited by double ‐clicking on the
object. Design Objects may be added using the design object toolbar on the left of the
screen and by drawing the approximate object placement on the card with the mouse.
To change the card size and orientation go to File ‐> Edit Page Setup. More details about
ID Flow Designer follow on subsequent pages.
After design modifications are finished click Exit and Save.
Other Settings
Use the Enrollment button on the Main Menu to enroll new cardholders. Modifications
to the enrollment process, record look up and logs and reports are configured in the
Cardholder Group Properties.
See records by clicking the Record Center button. Sample records may be deleted, but it
is suggested a new record be added first so that the data set is not empty.
User Accounts and Locations are configured in Global Settings and workstation tasks are
configured in Workstation Settings.
Quick Start Option 2:
Select “Launch Setup Wizard” from the Configure Workstation dialog at start up or run
from the Setup menu.

Name the cardholder group; then choose the database:

Select the card size and then click edit the badge design (see instructions below for ID
Flow Designer):

Then configure each tab of the Cardholder Group and Workstation Settings:

ID Flow Card Designer

ID Flow Card Designer is used to create ID card designs. A guided setup wizard will walk
you through selecting card stock, card format, single/double-sided, connecting to a data
source, selecting text and image fields for the design, setting a background and
password protection.
To use the wizard select Create new document and Use the guided setup wizard:

Databases
The setup wizard presents three database options:
1. Use existing database
2. Use sample database
3. Create a new MS Access database
To use an existing database: Select the database type, the location and its table, view or
join.

Jolly Products are open-data architecture. ID Flow has the ability to use existing data
sources as the basis for ID card design and production. The Database Settings dialog

shown above established a live connection to an existing database. Any modifications
to the schema and the data will apply instantly to the existing database.

Design Screen
The design screen contains four toolbars: general items, alignment tools, design objects
and object formatting.

Cards are designed by selecting the design object on the left-hand toolbar and by
drawing that object’s area on the card with the mouse. After the area drawn the
object’s Properties dialog will appear. Click through the tabs to format the object.

Objects may be resized at any time and Properties dialog re-accessed by double-click.

Working with Text
ID Flow contains rich text editing. Regular text, database text, serial number, date and
time may be combined within one text box. Type with a keyboard or use the + Field
button for text selections.

There are three types of text formatting: Text Box, Flexible Text and Circular Text. Text
Box will always place text within the bounds of the box drawn in the design: If larger, it
will auto-reduce in font size or word wrap. Flexible Text will maintain font size
regardless of the size of the box drawn. Circular Text formats text in a circle.

Working with Layers
Like other quality graphical design tools, ID Flow uses a layered design approach. Layers
may contain different design objects of varying opacity. Using layers adds a rich depth
to design and creates highly secure cards.
To see the layers window click the Show Layers checkbox on the top menu bar. Layers
are added using the [+] button at the bottom of the window. Use the arrow buttons to
move layers above and below other layers. Click the Print checkbox on each layer to
format its print condition. The active design layer is highlighted blue.

Viewing Designs with Live Data
At anytime the card design may be viewed with data by checking the Live Data button
on the top menu bar:

To view the full record set: go to File -> Database Setup or click the data icon on the top
menu bar:

Working with Print Conditions
Design objects or design layers may be set to print only if specific database conditions
are met. Print conditions are set on the Print Conditions tab of the object’s properties
dialog. K Panel (Black Panel) and UV Panel are also set on this tab.

Saving a File
Use File -> Save or Save as… to save and name the design. ID Flow files are saved with a
.jps extension. Though cards can be printed from the design screen or Database Setup,
design files are typically imported into the Card Issue Center for production.

ID Flow Card Issue Center
The Card Issue Center is used for day-to-day data entry and production of ID cards. It
allows the user to enroll new cardholders, lookup an existing record and view reports of
all actions that have occurred. The Record Center shows all database records and their
ID card design.

Card designs are typically first created in ID Flow Designer and then imported into ID
Flow Card Issue Center.
Card Issue Center is designed so that multiple locations may be networked through
sharing a central file. For this reason, there are two types of configuration settings:
Global and Workstation.
The Small Business Edition does not have networking abilities; however, it also contains
Global and Workstation settings.
To Setup, select the setup button on the Main Menu screen or from the Admin Menu.
Only Administrators have setup ability

Global Settings
Global Settings are configured in the Company Setup dialog. Depending on the edition,
it may contain Cardholder Groups, Locations, Logs and Reports, Security Policy, User
Accounts and the Company Source.

The Company Source is the central database file that, for networked versions, should be
placed on a secure internal server or shared workstation. For stand-alone copies it does
not need to be moved.
Settings for Locations, Logs and Reports Security Policy and User Accounts are obvious
when the dialog is open.
Cardholder Group settings work in tandem with Workstation settings. Examples: 1. In
order to capture a signature in the enrollment process, the signature field must be
defined in the cardholder group’s Enrollment tab; 2. In order to lookup a record by email
address, that field needs to be defined in Record Lookup tab; 3. In order to log the name
and titles of cardholders, those fields must be defined in the Logs and Reports tab.
To configure the cardholder group’s settings, highlight the group and select edit.

Workstation Settings
Workstation settings apply to the specific workstation. They include selecting the
location, cardholder groups available at this location, selecting which tasks will be
available to the user, configuring the tasks and capture devices, and selecting the
language to be used a this location. Tasks are configured individually through the task’s
blue hyperlink or together via the configure button:

Importing a Card Design
Card designs are typically first created in ID Flow Card Designer and then imported into
ID Flow Card Issue Center. To add a new card design, Go to Global Settings ->
Cardholder Groups and then select “Add.” This will open the Cardholder Group
Properties dialog.

Enter a Group Name then select Import on the Badge Printing tab. Browse to the .jps
file created in Card Designer. The option will be provided to import the designs
database with the design. If so, it will automatically populate the Card Database dialog.
Next, select the fields in the Enrollment, Record Lookup and Logs and Reports tabs.
Important note on imported designs: It is a copy of the design that is imported into
Card Issue Center. Changes made to the design using Card Designer, must be reimported for the changes to be reflected in Card Issue Center. Changes can be made
directly to the Card Issue Center copy by selecting Edit with ID Flow… in the Cardholder
Group Properties dialog. In this instance, changes made to the imported copy are not
reflected in the original copy.

Enrollment Configuration
Users define the relevant workflow for enrollment. Available steps include Data Entry,
Photo Capture, Signature Capture, Fingerprint Capture and Card Printing:

1.

3.

2.

4.

5.

To configure photo capture, driver’s license scan, signature capture and fingerprint scan
in enrollment, first define fields in the Cardholder Group Properties (Global Settings),
and then define the process available in the workstation settings:

The capture device specifications are configured by clicking the Options buttons in the
Workstation Task Settings.
Notes about capture devices:
ID Flow supports TWAIN and WIA compatible cameras. The ability to capture a photo
from within ID Flow and trigger the flash will depend upon the camera’s software. ID

Flow is commonly used with web cams: When Microsoft WDM is invoked as the capture
source, four photos are captured and the best may be chosen.

ID Flow supports Topaz and Interlink USB signature and fingerprint pads.
ID Flow support Card Scanning Solutions ScanShell 800, ScanShell 1000 and SnapShell
camera for driver’s license and/or passport scanning. It does NOT support the 800N.
Some device files and drivers may be found under “add-on modules” on the “Download”
section of the www.jollytech.com website.

Record Lookup Configuration
Record Lookup allows the user to quickly search for records. When multiple matches
occur a selection dialog is shown. Strict matching may be invoked.

To configure record lookup, first define the lookup fields in the Lookup Fields tab of
Cardholder Group Properties dialog found in Global Settings, then, define the options in
the Workstation Settings.

Report Center Configuration
Logs and Reports shows activity on all actions that occur in the product: when a record
was added, edited or deleted and when card was printed; by whom, at what time and
location. Custom logs may be designed. Reports may be printed, exported and emailed.

Four fields from a cardholder’s record may be configured in the Logs and Reports tab on
the Cardholder Group Properties dialog. The Workstation Setting for Logs and Reports
makes the item available or not.

Record Center
Record Center is used for the management of records. Records may be added, edited,
deleted, printed and duplicated from this screen. The down-arrow button provides
additional options.

Records may be viewed in single-record or spreadsheet view by selecting the buttons on
the right of the toolbar.

Records may be batch printed, deleted and edited by checking the box to the left of the
record and selecting the appropriate action. Records may be sorted by clicking on
column headers.
. Filters are used to create data
The toolbar contains filter and sort buttons
subsets. Sorting allows for multiple field sort criteria.

Configuring the Record Screen
ID Flow has drag-and-drop record screen formatting. Select Edit Record Layout from the
down-arrow menu on the Record Screen: Size and move fields with the mouse.

Advanced Field Formatting
ID Flow Enterprise Edition contains advanced field formatting. Fields may be made
Visible, Required and Read Only. They may be given default values. Drop-down lists

may be created. Text can be set to Capitalize, UPPER CASE or lower case. Image paths
may be created to store variable images to file.

Configuring Language
ID Flow is available in 10+ languages. Select the language in the Workstation Settings. A
translation table allows the user to make changes to the translation or to translate into
a language not yet provided by Jolly. After changing languages, restart the program.
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